Schneller zu validem Html mit Ubuntu und Eclipse


Tree on Monument Hill
Attribution-NonCommercial-NoDerivs License by zachstern

Valides Html ist wichtig – keine Frage. Leider ist der Weg dorthin oft beschwerlich, vor allem, wenn man wie ich eher selten damit arbeitet. Für größere PHP Sachen verwende ich Eclipse für „PHP Menschen“.  Wenn nun irgendwas mit meinem Html nicht stimmt, bekomme ich meist so ein kleines Ausrufezeichen, jedoch nicht immer.

phpnwe7CH

Deswegen bemühe (bemühte) ich häuft den Validator der W3C Seite, der endgültige Gewissheit über das Markup verschafft. Da ich meist lokal arbeite und auch nicht  Dyndns oder ähnliches verwenden möchte, hat sich das „Debuggen“ mit dem Validator immer in eine Copy & Paste Orgie verwandelt. Ein wenig Lesen auf der W3C Seite brachte mir diese schöne Erkenntnis:

All software developed at W3C is Open Source / Free software. Which means that you can download and use them for free, if you like. It also means that you are welcome to participate in making them better, cooler, more useful for you and everyone.

Juhu. Schnell stand fest, daß es da auch ein Ubuntu Paket namens w3c-markup-validator im Repository gibt. Nach der Installtion muß man  in der Datei /etc/w3c/validator.conf noch die Option Allow Private IPs auf yes setzen. Den Validator erreicht man unter http://localhost/w3c-markup-validator. Sehr schön.

Um den Validator bequem mit Eclipse zu nutzen, werden noch 5 Minuten Rumklicken benötigt. Mir reicht es, wenn ich per Mausklick die aktuelle Seite validieren kann. Dazu konfiguriere ich unter Run->External Tools->External Tools Configuration den Browseraufruf. Zu beachten wäre hierbei, daß der absolute Pfad zum Programm angegeben werden muß. (Ich verwende Chrome. Firefox findet man unter /usr/bin/firefox)

Hier der Screenshot des Fensters mit meinen Einstellungen:

phpo16zCr

Im Reiter common sollte man noch das Häckchen bei  „Allocate Console“ rausnehmen und „Launch in Background“ setzen.

Nun kann man bequem per Mausklick validieren:

phpjls8gg

Zum Ende bleibt nur noch zu fragen, wie Ihr euren HTML Krams validiert. Meine Lösung ist zwar relativ einfach, aber simpler gehts – finde ich –  immer 🙂

Advertisements
Dieser Beitrag wurde unter Allgemein, linux, webkrams abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

8 Antworten zu Schneller zu validem Html mit Ubuntu und Eclipse

  1. vonox7 schreibt:

    Ich habe schon seit einigen Jahren das Firefox Add-on Web Developer Toolbar installiert. ( https://addons.mozilla.org/en-US/firefox/addon/60/ ) (gibts auch für Chome auf https://chrome.google.com/extensions/detail/bfbameneiokkgbdmiekhjnmfkcnldhhm )
    Um dann eine lokale Website validieren zu lassen muss man nur bei der Toolbar auf Extras-> Lokales HTML validieren oder Strg-Umschalt-H drücken. Geht zwar nicht ganz so schnell wie deine Variante, ist aber weit einfacher einzurichten, und die Web Developer Toolbar bietet ja auch noch ein paar mehr Funktionen, auf die ich nicht mehr verzichten möchte 😉

  2. clonejo schreibt:

    Als Firefox-Addon gehts mit dem Html Validator: http://users.skynet.be/mgueury/mozilla/

  3. Maxe schreibt:

    Sehr schön. Das sollten sich mal einige selbsternannte (und eigtl. auch studierte) Webdesigner ansehen. Is echt unfassbar, was für Müll so ins Internet gelassen wird …

  4. aboettger schreibt:

    Danke dafür, jetzt muss ich es mir nur noch merken 🙂

  5. Abulafia schreibt:

    Man müsste vielleicht noch ergänzen: Das Pakte in den Repositories ist extrem veraltet (kein Versionsupdate seit hardy). Darum kann es auch kein HTML5 usw.

  6. der Parteivorsitzende schreibt:

    @Abulafia: Da hast Du recht. Bei dem Packet handelt es sich um ein Waisenkind (http://www.debian.org/devel/wnpp/orphaned.de.html). Spontan fällt mir nur ein, die Url im External Tools Fenster auf http://validator.w3.org/ zu ändern. Wenn ich Zeit habe, schau ich mal, ob ich nicht ein aktuelleres Packet finde / baue.
    Grüße:)

  7. Abulafia schreibt:

    @HerrVorsitzender: Das wäre mal super. Ich habe einmal versucht der Anleitung (http://validator.w3.org/docs/install.html) zu folgen und mir die aktuelle Version zu installieren. War aber dran gescheitert. Mit frischem Paket würde sich ein weiterer Anlauf für mich erübrigen.

  8. der Parteivorsitzende schreibt:

    @Abulafia: Ich hab gerade den euphemistischen Versuch hinter mich gebracht mir aus einem aktuellen RPM mit Alien ein Debian Package zu erstellen. Hat leider nicht gefruchtet:(. Ein einfacher Dateitausch innerhalb des aktuellen Deb’s wird es auch nicht bringen. Ich schaus mir die Tage mal den Bauvorgang genauer an und werde an prominenter Stelle über die Resultate berichten.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s